Memory Usage

Rob Burtelow rb1068 at STL.RURAL.USDA.GOV
Wed Mar 31 17:58:02 IST 2004

I'm running MailScanner on a RedHat ES 3 box and having problems with
really high memory usage, almost to the point of running out.  The
machine is an HP 4cpu 2.5ghz xeon box, with 4 GB of ram.  Here is the
output from free:

             total       used       free     shared    buffers     cached
Mem:          3621       3399        221          0        278       2731
-/+ buffers/cache:        389       3231
Swap:          529          0        529

The free memory keeps dropping and I'm afraid that its gonna run out and
eventually crash.  I tried restarting MailScanner several times to see
if it would free up some memory, it would free up about 100MB then start
dropping again.  When I run `top` MailScanner is the only process really
showing up as using any ram, but it is a small amount.  I did some
searching through the archives and found some old memory problems in
earlier versions, but nothing this new.

I had the concurrent processes sent to 10, moved it down to 8, then down
to 5, and haven't seen a change so far.  The machine does a lot of mail,
but our old box which we replace last week handled it all on a dual 800
with only 512 of RAM.  Has anyone else experienced any sort of memory
leak in mailscanner-4.28.6-1 ?


Rob Burtelow
Linux Administrator

More information about the MailScanner mailing list