MailScanner or Sendmail dropping the ball? (fwd)

Ian Miller imiller at BSD.UCHICAGO.EDU
Wed Mar 24 20:25:26 GMT 2004

Do you have Sunfreeware's perl installed??
and do you have all of the perl mod's installed for that version of perl?

I had the same problem a few weeks ago with two solaris 9 sendmail systems.
I removed the Sunfreeware perl and complied perl from source, 5.8.3
then installed all of the mod's....
if nothing else works try that.
Quoting MailScanner Mailbox <mailscan at PRIS.CA>:

> Hello All
> I am resending this to the list with a different subject line as the first
> may have led to some confusion. I have looked through the faq and also
> googled for an answer but cannot find one.
> At this point in time I now have over 8000 emails that are sitting in
> mqueue not being delivered. I do have queue runners trying and I am also
> trying from the command line.
> I do not know what else to do and have lost a lot of sleep over this.
> <Original Message>
> I recently noticed a problem that I really don't know what the cause is.
> We are running sendmail 8.12.10 on solaris 9, Mailscanner 4.27.7 and SA
> 2.63
> It appears as though a lot of email is just sitting in the queue and not
> being delivered. By the queue I mean mqueue not MS and SA have
> already worked their magic and all we need now is delivery
> When I try and run the queue I show that there are 200 or so messages and
> the queue starts running, but when I do a sendmail -bp there are actually
> over 3000 emails. I have tried everything and every switch and debug
> switch in the bat book but still these emails will not go. Some are as old
> as a week, some are only a few hours old.  Also some emails are bounces,
> some are for virtual domains on or system and some are for our regular
> members.
> What am I missing here?
> Rick

Ian Miller
Sr. Systems Engineer
University of Chicago
imiller at

More information about the MailScanner mailing list