Razor Install Problem (not finding SHA1)

Furnish, Trever G TGFurnish at HERFF-JONES.COM
Wed Jan 21 17:15:06 GMT 2004

Did you do an upgrade of this system?  Or maybe change the compiler or perl
version?  I'm not familiar with that particular error and not really
familiar with Dynaloader, but my guess would be that the version of
Digest::SHA1 you have installed was compiled either for a different version
of perl or on a different architecture or ... I'll stop before I start
imagining too much. :-)

The version of that module that you find in the filesystem is in a
vendor_perl directory.  That's different compared to my rh9 box.  I have one
in the vendor_perl directory, but I also have one in a site_perl directory,
and the site_perl directory is listed first in @INC, so that's the one that
gets used.

My setup notes say I installed Digest::SHA1 via cpan, but I didn't need to
use "force".  I'm not sure why it's telling you yours is up to date unless
maybe there was a package from redhat that I missed that included a more
up-to-date version of that module.

You might want to try getting more detailed in your cpan actions.  Instead
of just "install", do "test" and see what it says.  If it tells you it's
already up to date, then do "force test Digest::SHA1".

You also didn't send the output of one of the commands I suggested - you
might want to take a look there.  The command was:
        perl -e 'print join("\n", @INC, "\n");'

And on my system, it prints out:

And also fyi, on my system I have the following instances of SHA1-related
[root at relay en]# locate SHA1

(That last one is just the original rpm from redhat9.)

Hope it helps,

> -----Original Message-----
> From: Al Cooper [mailto:alc at TLYNX.COM]
> Sent: Tuesday, January 20, 2004 6:06 PM
> Subject: Re: Razor Install Problem (not finding SHA1)
> Thanks for responding.  Comments in line.
> >-----Original Message-----
> >From: MailScanner mailing list [mailto:MAILSCANNER at JISCMAIL.AC.UK]On
> >Behalf Of Furnish, Trever G
> >Sent: Tuesday, January 20, 2004 3:58 PM
> >Subject: Re: Razor Install Problem (not finding SHA1)
> >
> >
> >perl -e 'use Digest::SHA1;'
> [root at gate2 root]# perl -e 'use Digest::SHA1;'
> Digest::SHA1 object version 2.01 does not match bootstrap
> parameter 2.07 at
> /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 249.
> Compilation failed in require at -e line 1.
> BEGIN failed--compilation aborted at -e line 1.
> [root at gate2 root]#
> >
> >If you get an error about it not being found, then your
> problem is that
> it's
> >not installed correctly for the version of perl that you're
> using.  If
> >that's the case, then you may find it helpful to
> double-check which version
> >of perl is in your path:
> >
> >type perl
> >perl -v
> [root at gate2 root]# perl -v
> This is perl, v5.8.0 built for i386-linux-thread-multi
> (with 1 registered patch, see perl -V for more detail)
> Copyright 1987-2002, Larry Wall
> Perl may be copied only under the terms of either the
> Artistic License or
> the
> GNU General Public License, which may be found in the Perl 5
> source kit.
> Complete documentation for Perl, including FAQ lists, should
> be found on
> this system using `man perl' or `perldoc perl'.  If you have
> access to the
> Internet, point your browser at http://www.perl.com/, the
> Perl Home Page.
> >
> >It might also help to print out your @INC:
> >perl -e 'print join("\n", @INC, "\n");'
> >
> >Then again, I don't think that zero should be there either
> in the warning
> >message you're getting, so you may have a very different problem.
> >
> >HTH,
> >Trever
> >
> > -----Original Message-----
> > From: Al Cooper [mailto:alc at TLYNX.COM]
> > Sent: Tuesday, January 20, 2004 5:07 PM
> > Subject: Razor Install Problem (not finding SHA1)
> >
> >
> > I am attempting to install Razor 2.36 on a Redhat 9 box
> > running MS 4.25-14.
> > I install the Razor SDK package with no problem.  When I
> > tried to start
> > installing Razor by running 'perl Makefile.PL' from the
> > razor-agents-2.36
> > directory, I get the following error 'Warning: prerequisite
> > Digest::SHA1 0
> > not found'.  However I run from / 'find . -name SHA1' I find
> > that SHA1 is
> > located at
> > '/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto
> > /Digest/SHA1'.
> > I also tried to re-install Digest::SHA1 via MCPAN and I get
> > the message
> > "Digest::SHA1 is up to date."
> >
> > Any suggestions?
> >
> > Thanks for your help.
> >
> > Al Cooper
> >

More information about the MailScanner mailing list