Razor Install Problem (not finding SHA1)

Al Cooper alc at TLYNX.COM
Tue Jan 20 23:06:15 GMT 2004

Thanks for responding.  Comments in line.

>-----Original Message-----
>From: MailScanner mailing list [mailto:MAILSCANNER at JISCMAIL.AC.UK]On
>Behalf Of Furnish, Trever G
>Sent: Tuesday, January 20, 2004 3:58 PM
>Subject: Re: Razor Install Problem (not finding SHA1)
>perl -e 'use Digest::SHA1;'

[root at gate2 root]# perl -e 'use Digest::SHA1;'
Digest::SHA1 object version 2.01 does not match bootstrap parameter 2.07 at
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 249.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
[root at gate2 root]#

>If you get an error about it not being found, then your problem is that
>not installed correctly for the version of perl that you're using.  If
>that's the case, then you may find it helpful to double-check which version
>of perl is in your path:
>type perl
>perl -v

[root at gate2 root]# perl -v

This is perl, v5.8.0 built for i386-linux-thread-multi
(with 1 registered patch, see perl -V for more detail)

Copyright 1987-2002, Larry Wall

Perl may be copied only under the terms of either the Artistic License or
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.
>It might also help to print out your @INC:
>perl -e 'print join("\n", @INC, "\n");'
>Then again, I don't think that zero should be there either in the warning
>message you're getting, so you may have a very different problem.
> -----Original Message-----
> From: Al Cooper [mailto:alc at TLYNX.COM]
> Sent: Tuesday, January 20, 2004 5:07 PM
> Subject: Razor Install Problem (not finding SHA1)
> I am attempting to install Razor 2.36 on a Redhat 9 box
> running MS 4.25-14.
> I install the Razor SDK package with no problem.  When I
> tried to start
> installing Razor by running 'perl Makefile.PL' from the
> razor-agents-2.36
> directory, I get the following error 'Warning: prerequisite
> Digest::SHA1 0
> not found'.  However I run from / 'find . -name SHA1' I find
> that SHA1 is
> located at
> '/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto
> /Digest/SHA1'.
> I also tried to re-install Digest::SHA1 via MCPAN and I get
> the message
> "Digest::SHA1 is up to date."
> Any suggestions?
> Thanks for your help.
> Al Cooper

More information about the MailScanner mailing list