Razor Install Problem (not finding SHA1)

Furnish, Trever G TGFurnish at HERFF-JONES.COM
Tue Jan 20 22:57:35 GMT 2004

What happens if you run the following:

perl -e 'use Digest::SHA1;'

If you get an error about it not being found, then your problem is that it's
not installed correctly for the version of perl that you're using.  If
that's the case, then you may find it helpful to double-check which version
of perl is in your path:

type perl
perl -v

It might also help to print out your @INC:
perl -e 'print join("\n", @INC, "\n");'

Then again, I don't think that zero should be there either in the warning
message you're getting, so you may have a very different problem.


> -----Original Message-----
> From: Al Cooper [mailto:alc at TLYNX.COM]
> Sent: Tuesday, January 20, 2004 5:07 PM
> Subject: Razor Install Problem (not finding SHA1)
> I am attempting to install Razor 2.36 on a Redhat 9 box
> running MS 4.25-14.
> I install the Razor SDK package with no problem.  When I
> tried to start
> installing Razor by running 'perl Makefile.PL' from the
> razor-agents-2.36
> directory, I get the following error 'Warning: prerequisite
> Digest::SHA1 0
> not found'.  However I run from / 'find . -name SHA1' I find
> that SHA1 is
> located at
> '/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto
> /Digest/SHA1'.
> I also tried to re-install Digest::SHA1 via MCPAN and I get
> the message
> "Digest::SHA1 is up to date."
> Any suggestions?
> Thanks for your help.
> Al Cooper

More information about the MailScanner mailing list