Debian wierdness

Eric Dantan Rzewnicki rzewnickie at RFA.ORG
Wed Feb 4 23:34:03 GMT 2004

We also had issues around the time we did the perl update. I couldn't
exactly pin it down to being related vs. just a coincidence. But, in our
case the bayes database seemed to have gotten corrupted somehow around
the time of the upgrade. Again, I'm not certain it's related, but I have
not had any other issues with the bayes database previously.

After I moved the existing bayes_* files asside everything was fine ...
I retrained bayes with my saved corpus of ~1000 known spam and several
thousand more site specific known ham.

-Eric Rz.

[OT] PS We have this line in our crontab to check for new packages every

05 5    * * *   root    apt-get -qq update && apt-get -dqq upgrade && apt-get -sqq upgrade

It checks for and downloads updated packages, but does not install them.
When there are new packages root gets an email. Another good thing is to
subscribe to the debian security announce list. That way you get an
explanation for any packages updated for security fixes. -edrz

On Wed, Feb 04, 2004 at 11:05:47PM -0000, Faye Mitchell wrote:
> Hi,
> Just curious (and hopefull) - has any other debian user experienced
> this?
>  Mailscanner/exim/SpamAssassin combo working perfectly (although
> struggling a little under MyDoom :-) ) on my little debian box. Next day,
> Mailscanner is pointblankly refusing to copy messages from the
> incoming exim mail spool to the outgoing one. The previous evening I
> installed routed and I noticed dselect picked up some security updates
> for perl modules. Apart from that, no change to the box or to any of the
> config files.
> I tried putting Mailscanner into debug mode, but all mailscanner is
> saying is that it's starting and then no more logs from Mailscanner. It's
> still happily running as witnessed by top, and kicking in and out as it
> should - it's just not doing anything :-(. I tried putting the AV to none
> (thinking that may Sophos was causing the problem), but still no joy :-(
> I tried doing a debug run and it seemed to be trying to start up SA
> (despite the Spam Checks config option being set to no - for a variety
> of reasons (primarily performance related) I want exim to do the Spam
> checks, not MailScanner) and getting no where. I altered the config file
> so that use SpamAssassin was set to no, and commented out the lines
> in the mail MailScanner prog that initialised it to be on the safe side.
> And now it starts working.
> Has anybody else experienced this and knows why it behaved the way
> it did? I've got the thing working, but I'd kind of like to know why it
> stopped working in the first place!
> Faye
> --
> -=+=-
> Faye Mitchell, Senior Lecturer,
> Department of Computing,
> Oxford Brookes University
> email frmitchell at
> PGP public Key @
> Tel. Work +44 1865 48 4544
> Disclaimer: The views represented here, should in no way be taken to
> be the opinion or views of Oxford Brookes University.
> -=+=-
> Thought for the day:
>     Light? Heck I can't even see the tunnel!

More information about the MailScanner mailing list