Debian wierdness

Faye Mitchell frmitchell at BROOKES.AC.UK
Wed Feb 4 23:05:47 GMT 2004


Just curious (and hopefull) - has any other debian user experienced

 Mailscanner/exim/SpamAssassin combo working perfectly (although
struggling a little under MyDoom :-) ) on my little debian box. Next day,
Mailscanner is pointblankly refusing to copy messages from the
incoming exim mail spool to the outgoing one. The previous evening I
installed routed and I noticed dselect picked up some security updates
for perl modules. Apart from that, no change to the box or to any of the
config files.

I tried putting Mailscanner into debug mode, but all mailscanner is
saying is that it's starting and then no more logs from Mailscanner. It's
still happily running as witnessed by top, and kicking in and out as it
should - it's just not doing anything :-(. I tried putting the AV to none
(thinking that may Sophos was causing the problem), but still no joy :-(

I tried doing a debug run and it seemed to be trying to start up SA
(despite the Spam Checks config option being set to no - for a variety
of reasons (primarily performance related) I want exim to do the Spam
checks, not MailScanner) and getting no where. I altered the config file
so that use SpamAssassin was set to no, and commented out the lines
in the mail MailScanner prog that initialised it to be on the safe side.

And now it starts working.

Has anybody else experienced this and knows why it behaved the way
it did? I've got the thing working, but I'd kind of like to know why it
stopped working in the first place!



Faye Mitchell, Senior Lecturer,
Department of Computing,
Oxford Brookes University
email frmitchell at
PGP public Key @
Tel. Work +44 1865 48 4544
Disclaimer: The views represented here, should in no way be taken to
be the opinion or views of Oxford Brookes University.

Thought for the day:
    Light? Heck I can't even see the tunnel!

More information about the MailScanner mailing list