Problem s with allowing exe-attachments for a signel domain

John Bergbom d99-jbe at NADA.KTH.SE
Tue Aug 31 00:23:25 IST 2004


I'm running a server with many domains, and one of our customers wants to
allow exe-attachments. I followed the steps in the FAQ, but it still
doesn't work for me. This is what I did:

In MailScanner.conf:
Filename Rules = %etc-dir%/rules/filename.rules
Filetype Rules = %etc-dir%/rules.filetype.rules

In rules/filename.rules:
To: *    %etc-dir%/filename.exeok.rules.conf
FromOrTo: default %etc-dir%/filename.rules.conf

In rules/filetype.rules:
To: *    %etc-dir%/filetype.exeok.rules.conf
FromOrTo: default %etc-dir%/filetype.rules.conf

In %etc-dir%/filename.rules.conf:
deny     \.exe$    Windows/DOS Executable

In %etc-dir%/filename.exeok.rules.conf:
allow     \.exe$    Windows/DOS Executable

In %etc-dir%/filetype.rules.conf:
deny     executable    No executables      No programs allowed

In %etc-dir%/filename.exeok.rules.conf:
allow     executable    No executables      No programs allowed

This has worked for others, but not for me. When I try to send an email to
test at I get this in return:

From: Mail Delivery System
Subject: Mail delivery failed: returning message to sender

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

test at
  This message has been rejected because it has
  a potentially executable attachment "temp.exe"
  This for of attachment has been used by recent
  viruses or other malware. If you meant to send
  this file then please package it up as a zip
  file and resend it.

SOMETHING is working though, because in the returned header there is a
X-yoursite-MailScanner: Not scanned: please contact your Internet E-Mail
Service Provider for details

So my problem is (from what I understand): The Filename Rules and Filetype
Rules lets the exe-attachment get through, but then there is something
else that stops the file from getting through, and I can't figure out what
it is. I tried to set Virus Scanning for all domains except the domain in
question, but the same error occurred.

Before I made any changes to the MailSCanner.conf-file I got the usual
yoursite-Attachment-Warning.txt message, saying the the attachment has
been replaced with a warning message.

Please help me with this, it's important for us, and I can't figure out
what is wrong, and I haven't been able to find an answer to this in the
FAQ or in the mailing list archives.


------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the MAQ ( and
the archives (

More information about the MailScanner mailing list