Mailscanner and Postfix problems

Roel Gloudemans roel at GLOUDEMANS.INFO
Tue Aug 24 08:24:00 IST 2004

Hi List,

(postfix 2.1.4)
(mailscanner 4.32.5)

I'vo got a problem with my mailscanner installation. Now and then, when
mailscanner drops an e-mail back into the postfix queue postfix gives the
following error messages:

[ID 947731 mail.warning] warning: corrupted queue file: active/2/255D4A1F
[ID 947731 mail.crit] panic: smtp_rcpt_cleanup: recipient count mismatch: 0+0!=1
[ID 947731 mail.warning] warning: premature end-of-input on private/smtp socket
while reading input attribute name
[ID 947731 mail.warning] warning: private/smtp socket: malformed response
[ID 947731 mail.warning] warning: transport smtp failure -- see a previous
warning/fatal/panic logfile record for the problem description
[ID 947731 mail.warning] warning: process /usr/local/libexec/smtp pid 25463
killed by signal 6

I've searched the list and found similar problems before. However, the list
suggested they're solved. So I upgrade MailScanner to the last stable release
4.32.5 . However, the loglines you see above were generated after this upgrade.
So the problem isn't solved. Worth to mention is the fact that this mail was
classified as spam (which is wasn't, but that's about too tight spamassassing

I use postfix 2.1.4 in a single server setup (postix dumps to the hold queue,
mailscanner picks it up and drops it in the incoming queue)

Can anyone provide me with any help with this problem?


------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the MAQ ( and
the archives (

More information about the MailScanner mailing list