readqf: cannot open ./d* (including last MailScanner)

Mariano Absatz mailscanner at LISTS.COM.AR
Mon Oct 6 16:46:02 IST 2003

I'm not sure, but I think this might be due to the following: in batch mode 
(IIRC the default for MailScanner+Sendmail), MS puts all the queue files 
(qfiles & dfiles) from a batch in /var/mqueue, and then manually invokes 
sendmail to deliver them.

However, there's a sendmail process traversing that queue every 15 minutes 
(by default, you can change that). 

If the automatic sendmail queue processing happens after MS has put a given 
qf+df pair, but before it issues the manual sendmail, the auto sendmail will 
deliver the message and the manual sendmail will fail ('cause its list of 
queue files is manually created within MS).

I'd say you shouldn't care about that... Otherwise, you can try putting 
MailScanner in queue mode:
Delivery Method = queue

And maybe changing the automatic sendmail scanning so it runs more often 
(e.g. every 5 minutes)... for this you have to edit 
/etc/rc.d/init.d/MailScanner and change the value of the variable QUEUETIME


El 6 Oct 2003 a las 12:10, Ramon escribió:

> Hello,
> My config:
> - MailScanner-4.11-1 but today I have tried too MailScanner-4.24-5 and
>   the errors has increased considerably (may be because it's faster?)
> - mcafee
> - Sendmail 8.12.3-6.6
> - Linux Kernel 2.4.22
> I've got lots of this annoying error in my logs and although
> the messages are sent correctly sendmail generates an error mail
> to the sender for every message with this log. I woudn't care about
> this cause as I said all the messages are sent but my users complain
> about the error messages they receive.
> An example:
> ------------------------------------------------
> grep h95LST48031790: mail.log
> Oct  5 23:28:30 avant sm-mta[31790]: h95LST48031790:
> from=<julianov57 at>, size=1659, class=0, nrcpts=1,
> msgid=<BAY7-F88YEIEktho3sD0000c56e at>, proto=ESMTP,
> daemon=MTA, []
> Oct  5 23:28:40 avant sm-mta[31815]: h95LST48031790:
> to=<sf2 at>, delay=00:00:10, xdelay=00:00:00, mailer=local,
> pri=120651, dsn=2.0.0, stat=Sent
> --> Here the message has been sent but...
> Oct  5 23:28:49 avant sendmail[31827]: h95LST48031790: SYSERR(root):
> readqf: cannot open ./dfh95LST48031790: No such file or directory
> After sending it seems to trying to process it again!!
> Oct  5 23:28:49 avant sendmail[31827]: h95LST48031790:
> to=<sf2 at>, delay=00:00:19, xdelay=00:00:00, mailer=local,
> pri=120651, dsn=5.2.3, stat=Service unavailable
> Oct  5 23:28:49 avant sendmail[31827]: h95LST48031790: h95LSn62031827:
> DSN: Service unavailable
> ---------------------------------------------------
> In the list archives are some people asking about this error but I think
> there's no solution yet.
> If I'm not wrong MailScanner puts the scanned messages from to
> mqueue and then a 'sendmail -q -OQueueDirectory=/var/spool/mqueue'
> process this queue. Could it be that mailscanner put first the mail
> header (./q*) and then the data (./d*) if the time between the copy of
> the header and the data would be substantial (for example 1 or more
> seconds) that would explain the problem, but I don't know how to monitor
> this.
> It's not a fs lock problemm I have updated to kernel 2.4.22 where the 
> flock() is now Posix 2001 compatible (actually from 2.4.21 is
> compatible).
> Today I have upgraded to MailScanner 4.24-5 but there were many more 
> readqf error messages so I've downgraded after some hours (the rest
> worked perfectly and faster! ;-)
> We'll keep trying to find out a solution, any help would be appreciated.
> Ramon Acedo.

Mariano Absatz
El Baby
Marriage is a fine institution - but I'm not ready for an institution.
      -- Mae West

More information about the MailScanner mailing list