I was wrong...Sophos still not working.

Julian Field mailscanner at ecs.soton.ac.uk
Wed Oct 1 08:47:07 IST 2003

At 18:48 30/09/2003, you wrote:
>You might try editing the sophos-wrapper script and changing PackageDir
>to point to the directory containing sweep.
>John L wrote:
>> From the previous post, I removed Sophos, then installed it using the
>>Sophos.install script
>>All looked fine, but clamav is doing all of the virus scans.  Sophos is
>> From virus.scanners.conf
>>sophos          /usr/lib/MailScanner/sophos-wrapper
>>When I run the sophos-wrapper, I still get:
>>/usr/lib/MailScanner/sophos-wrapper: /bin/sweep: No such file or
>>/usr/lib/MailScanner/sophos-wrapper: exec: /bin/sweep: cannot execute:
>>No such file or directory
>>Any suggestions?

The correct syntax for scanning the current directory with sophos-wrapper is
/usr/lib/MailScanner/sophos-wrapper /usr/local/Sophos .
then you should find it works. Don't forget the "." off the end.

Julian Field
MailScanner thanks transtec Computers for their support

More information about the MailScanner mailing list