MS not logging in Solaris 9

Julian Field mailscanner at
Tue Nov 18 19:26:21 GMT 2003

For the Solaris users out there who are still having trouble with this, try
this patch to

---     2003-11-09 15:25:22.000000000 +0000
+++      2003-11-18 19:23:42.000000000 +0000
@@ -67,11 +67,11 @@
      # This was too simple and didn't work on some Solaris and IRIX systems
      #eval { Sys::Syslog::setlogsock('unix'); }; # This may fail!
      eval {
-      if ($^O =~ /solaris|sunos|irix/i) {
-        Sys::Syslog::setlogsock('stream');
-      } else {
+      if ($^O !~ /solaris|sunos|irix/i) {
-      }
+      } # else {
+        # Sys::Syslog::setlogsock('stream');
+      # }
      Sys::Syslog::openlog($name, 'pid, nowait', $facility);

At 23:09 17/11/2003, you wrote:
>I'm sorry, but I don't think I can help since everything has worked
>right out of the box for me for several versions. I have not changed
>anything regarding logging in Solaris or MS. I have read about Solaris
>log problems on this list a few times before but never had those
>problems myself so I didn't pay much attention. Have you searched the
>I'm still on 4.23 though, maybe it's a new problem. I'm gonna test the
>latest beta on my test system this week, I will post if I have a problem
>but Julian can probably help you right away. I can't post from work but
>if your problem is not solved tomorrow I will post my log configs this
>time tomorrow from home for comparison.
>/Peter Bonivart
>--Unix lovers do it in the Sun
>Sun Fire V210, Solaris 9, Sendmail 8.12.10, MailScanner 4.23-11,
>SpamAssassin 2.60 + DCC 1.2.9, ClamAV 20030829
>MailScanner Mailbox wrote:
>>Hello All specifically Peter or other Solaris 9 users
>>As well as the other problems I am having (patching Mimetools etc)
>>I have downloaded the latest beta of MS in my hopes of getting something
>>to work. I no longer get the errors while in Debug Mode (Yeah Julian)
>>however I am not getting any logging at all. Not with the beta version,
>>the stable version, or the production version I have running on a Solaris8
>>I do have the following in syslog.conf: mail.debug /var/maillog same as on
>>my production box. I know MailScanner is running as I get a postmaster
>>message when sending the eicar test virus through.
>>So I figured as you are running Solaris 9 perhaps you may have some
>>insight as to why I have no logging

Julian Field
Professional Support Services at
MailScanner thanks transtec Computers for their support
PGP footprint: EE81 D763 3DB0 0BFD E1DC  7222 11F6 5947 1415 B654

More information about the MailScanner mailing list