Installation on SuSe 7.1

Michael Meyer mime at GMX.DE
Tue Jan 14 20:16:04 GMT 2003

Johannes wrote:
> Hi, I just tried to install MailScanner on my SuSE 7.1 installation. Semms
> to work fine as Mailscanner starts correct, but when it tries to start the
> sendmail deamon I get Error Messages:
> mail2:~ # rcMailScanner start
> Initializing sendmail and MailScanner/usr/sbin/sendmail: illegal option -- A
> startproc:  exit status of /usr/sbin/sendmail: 64
> /usr/sbin/sendmail: illegal option -- A
> startproc:  exit status of /usr/sbin/sendmail: 64

remove any '-A' from '/etc/sysconfig/MailScanner' and from


,-----[ /etc/init.d/Mailscanner ]
| if test "$SMTPD_LISTEN_REMOTE" != "yes" ; then
| SENDMAIL_IN_ARGS="-O DaemonPortOptions=Addr=

change 'DaemonPortOptions=Addr=' to whatever you needed. eg
to 'DaemonPortOptions=Addr='.

change msppid in '/etc/init.d/Mailscanner' to
'msppid=/var/run/' or whatever, because there is no
'clientmqueue' in SuSE 7.1.

i hope i didn't forget something. that's _my_ way to get it work
under 7.1.

> But I have got 5 Instances of Mailscanner running after trying to start it:


> I/usr/lib/MailScanner /usr/sbin/MailScanner /et
> 19920 pts/0    R      0:00 ps ax
> mail2:~ # check_MailScanner
> MailScanner running with pid 19914 19915 19916 19917 19918 19919
> Only the Sendmal deamon semms not to start...
> whats wrong with my Installation? Any Suggestions?
> I have the SuSE 8.0 RPM installed, any Problems with that on SuSE 7.1? Is
> There a RPM for SuSE 7.1? I also tried the source RPM, without success...

there is no RPM for SuSE <8.0. there are a few differences between
SuSE <8.0 and <=8.0. but with a little bit of work it is possible to
get it work.

sorry for my bad english.


More information about the MailScanner mailing list