Redhat 8.0 / command: service MailScanner status

Julian Field mailscanner at
Thu Nov 7 21:17:59 GMT 2002

At 21:07 07/11/2002, you wrote:
>On Thu, 7 Nov 2002 20:09:22 +0000, Julian Field
><mailscanner at ECS.SOTON.AC.UK> wrote:
> >>Not working still having a failure on sendmail outgoing. When I
> >>did a reboot I noticed a error "/etc/rc6.d/K30MailScanner" and
> >>at some times the error "We haven't got any child processes,
> >>which isn't right!, No child processes at /usr/sbin/MailScanner
> >>line 191. We have just tried to reap a process which wasn't one
> >>of ours!, No child processes at /usr/sbin/MailScanner line 194."
> >Check your maillog to see if MailScanner output something useful in there.
>from /var/log/messages
># service sendmail stop
>Nov  7 21:52:41 bromberg2 sendmail: sendmail shutdown succeeded

That stopped the sendmail process which your next command also tried to
stop, so there's little womnder why it complained. Once using MailScanner,
don't start up or shut down sendmail using the sendmail init script.
MailScanner handles all that for you.

># service MailScanner stop
>Nov  7 21:52:53 bromberg2 MailScanner: MailScanner shutdown succeeded
>Nov  7 21:52:53 bromberg2 MailScanner: sendmail shutdown succeeded
>Nov  7 21:52:53 bromberg2 MailScanner: sendmail shutdown failed
># service MailScanner start
>Nov  7 21:53:25 bromberg2 MailScanner:  succeeded
>After a clean boot from /var/log/maillog, MailScanner output
>5 times this for each process started from mailscanner.conf (?)

This is because you have "Max Children = 5" in your /etc/MailScanner.conf
file, and the log entries are produced as each of the 5 parallel processes

>bromberg2 sendmail[516]: alias database /etc/aliases rebuilt by root
>bromberg2 sendmail[516]: /etc/aliases: 62 aliases, longest 10 bytes,
>           599 bytes total
>bromberg2 sendmail[525]: starting daemon (8.12.5): SMTP
>bromberg2 sendmail[530]: starting daemon (8.12.5): queueing at 00:15:00
>bromberg2 MailScanner[546]: MailScanner
>bromberg2 MailScanner[546]: MailScanner E-Mail Virus Scanner
>           version 4.05-3 starting...
>bromberg2 MailScanner[546]: Using locktype = flock
>None of the above service commands produces logs
>in maillog, even the reap errors etc are not logged just
>send to console..

The reap errors should stop in the next release. It is just down to the
exact order in which the "stop" actually kills off the processes.

>  I'm a bit lost is it my sendmail or
>mailscanner messing up?

Neither. I hope I have explained it well enough for you to understand.

>  Is their anyone on the list who
>had a successful redhat 8.0 and latest MailScanner
>combination running?

Yes, lots of sites are happily running RH8 and MS4.
Including me of course :-)
Julian Field                Teaching Systems Manager
jkf at         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list