Problem with "Compile SpamAssassin Once" (Addendum)

Julian Field mailscanner at
Sun Jun 30 14:44:17 IST 2002

What version of Perl are you using? It has to be a Perl/SpamAssassin
problem. Try upgrading to Perl 5.6.1 then re-install SpamAssassin and see
if that cures it.

The other alternative is that it is failing to read one of your "rule
scores" files. If you uninstall SpamAssassin, then go round and find the files and user_prefs files and stuff like that, to ensure
that you have *completely* removed it, then re-install SpamAssassin. Just
upgrading SpamAssassin probably won't touch your SA config files.

I have just done a little search of my SA installation and the 25FREEMEGS
text is mentioned in (in /usr/lib/perl5/site-perl/5.6.1).
Ensure you delete this file before re-installing SA.

At 20:10 29/06/2002, you wrote:
>>Julian Field wrote:
>>>Have you tried upgrading SpamAssassin to 2.31?
>I just noticed that the same error message is echoed to the control tty
>MailScanner is started from. I usually login with ssh, upgrade, start
>and logout. The terminal was still active when a message was sent, and I
>get the same message. The difference is that I now only get it when a
>message is sent (and SA is activated). I will have to disable SA for now...
>Hope this helps. BTW, I'm seeing some other strange behaviour when
>reporting that a virus is detected, more on that later.

Julian Field                Teaching Systems Manager
jkf at         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list