SpamAssassin 2.30

Kelly Hamlin fizz at BOMB.NET
Sun Jun 16 14:49:01 IST 2002

hrmm, spamassassin installed fine on my primary gateway mail server, however
on my secondary, it all install fine, but when i goto restart mailscanner
(3-20-3) this is what i get..

Starting virus scanner...
root at grael:/opt/mailscanner/bin# Bareword found where operator expected at
(eval 37) line 764, near "25FREEMEGS_URL_body_test"
        (Missing operator before FREEMEGS_URL_body_test?)
Bareword found where operator expected at (eval 37) line 2854, near
        (Missing operator before FREEMEGS_URL_body_test?)
Failed to compile body SpamAssassin tests, skipping:
        (syntax error at (eval 37) line 764, near "25FREEMEGS_URL_body_test
Can't use global $_ in "my" at (eval 37) line 766, near ";
           $_ "
syntax error at (eval 37) line 2854, near "25FREEMEGS_URL_body_test"
syntax error at (eval 37) line 3647, near ";
Failed to run DIFFERENT_REPLY_TO SpamAssassin test, skipping:
        (Can't locate object method "check_for_spam_reply_to" via package
"Mail::SpamAssassin::PerMsgStatus" (perhaps you forgot to load
"Mail::SpamAssassin::PerMsgStatus"?) at
/usr/lib/perl5/site_perl/Mail/SpamAssassin/ line 1701.

Not a huge deal since this server only sees about 10k mail a day..

Any ideas? ive tried redownloading, and reinstalling several times.

----- Original Message -----
From: "Julian Field" <jkf at ECS.SOTON.AC.UK>
Sent: Saturday, June 15, 2002 8:53 AM
Subject: SpamAssassin 2.30

> A new SpamAssassin has just been released. You can download it from
> Install
> =======
> Installing 2.30 was a bit messier than it should have been. You need to
> install Time-HiRes from CPAN first
>         perl -MCPAN -e shell
>         install Time-HiRes (or was it Time::HiRes?)
> and if you are using gcc on Solaris then you'll need to remove all the
> "-xO3 -xdepend" from all the Makefiles as you go.
> make test
> =========
> And it couldn't start spamd even when I tried shutting down MailScanner
> first, so I don't know what's wrong there. You can skip the spamd tests by
> doing
>         cd t
>         rm spamd*
>         cd ..
> before you "make test". You can quite safely skip spamd altogether as
> MailScanner doesn't use it anyway.
> In Use
> ======
> And SpamAssassin keeps spitting out "sh: dccproc: not found" errors as I
> don't have the DCC system installed. But according to the SpamAssassin
> README, it's optional anyway. I suspect these can be stopped by adding
>         score DCC_CHECK 0.0
> to the spam.assassin.prefs.conf file.
> Summary
> =======
> The good news is that once I got it installed happily, it seems to be
> working just fine.
> --
> Julian Field                Teaching Systems Manager
> jkf at         Dept. of Electronics & Computer Science
> Tel. 023 8059 2817          University of Southampton
>                              Southampton SO17 1BJ

More information about the MailScanner mailing list