Julian Field jkf at ecs.soton.ac.uk
Tue Oct 2 15:22:27 IST 2001

At 23:36 01/10/2001, you wrote:
>Just ran a test of the new timeouts, a 600k file that expands out into a few
>hundred megabytes. The "Commerical scanner timed out!" message appeared in
>the syslog after 5mins, although the sweep process is still thrashing away
>on the same message? (its been going now for 26mins on the one file, and the
>mail queue is at a complete stand still and growing by the second with other
>mail hotfooting it into the queue).

I have just tried this on a Solaris 8 system and the timeouts worked
nicely. It did scan the same thing 3 times (once as part of batch scan,
next as part of individual message scan, third time to attempt
disinfection), but that's as expected.

If you do:
         while :
           ps -fe | grep sweep
and watch the total CPU time of the sweep processes, do they ever exceed
the value set in the timeout setting in the mailscanner.conf file?
Julian Field                Teaching Systems Manager
jkf at ecs.soton.ac.uk         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list