Cannot find Socket (/var/run/clamd.scan/clamd.sock) Exiting!

Macheta, Andy Andy.Macheta at
Tue May 2 15:28:01 UTC 2023

Hi all,
I'm hoping someone on the list can provide some fix for this as I'm struggling to!

I'm running a test VM (Alma Linux 9) with Spamassassin/Postfix/MailScanner/clamd at scan but it looks like the problem is with the socket even though it exists and has the right permissions:

srw-rw----. 1 clamscan virusgroup 0 May  2 15:09 /var/run/clamd.scan/clamd.sock

If I run /usr/lib/MailScanner/wrapper/clamav-wrapper /usr /tmp
it finds the EISCAR test virus in /tmp which makes me think that clamav install is all OK

The error message I'm seeing in 'Mailscanner --lint' is:

Virus Scanning: No virus scanners worked, so message batch will be tried again at /usr/share/MailScanner/perl/MailScanner/ line 583.
Cannot find Socket (/var/run/clamd.scan/clamd.sock) Exiting! at /usr/share/MailScanner/perl/MailScanner/ line 2413.

Thanks in advance for any help/guidance.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the MailScanner mailing list