MailScanner Lint Error

Paul Scott sales at
Wed Aug 12 02:51:08 UTC 2020

Hello Shawn,

Awesome!  That did the trick!  I am not sure of the reason why, but it appears that ms-sendmail starts a different sendmail configuration?

I used to have a startup script that restarted mailscanner and sendmail all together in one swoop.  Do you know where I could get that?

I had a perfectly good working configuration, and the building had a total blackout, and this somehow wacked my firewall, this server, and an Exchange server.

Also, do you know of a good reference on how to install DCC and Pyzor?

Thank you again for your assistance.  It is very much appreciated.  I'll be sure to donate on your site.


Paul Scott
Engineer, Eden USA, Incorporated
866.501.3336<tel:866.501.3336> | 951.505.6967<tel:951.505.6967> | sales at<mailto:sales at><>

From: MailScanner < at> On Behalf Of Shawn Iverson via MailScanner
Sent: Tuesday, August 11, 2020 2:30 AM
To: mailscanner at
Cc: Shawn Iverson <shawniverson at>
Subject: Re: MailScanner Lint Error

Are you running sendmail? If so...
chkconfig sendmail off
chkconfig sm-client off
chkconfig ms-sendmail on
service ms-sendmail start

On 8/10/20 9:02 PM, Paul Scott wrote:
Oh, and the running OS is CentOS 6.  Sorry, I should have put that in the email.

Thank you!

Paul Scott
Engineer, Eden USA, Incorporated
866.501.3336<tel:866.501.3336> | 951.505.6967<tel:951.505.6967> | sales at<mailto:sales at><>

From: MailScanner < at>< at> On Behalf Of L.P.H. van Belle via MailScanner
Sent: Monday, August 10, 2020 12:54 PM
To: mailscanner at<mailto:mailscanner at>
Cc: L.P.H. van Belle <belle at><mailto:belle at>
Subject: Re: MailScanner Lint Error

I don't know your running os, but on debian, running su-update is done as the user running the service.

i suspect wrong rights somewhere.
i had it myself, also due running sa-update as root.

I hope it helps.


Op 10 aug. 2020 21:08 schreef Paul Scott <sales at<mailto:sales at>>:

Hello MailScanner folks and friends:

I continue to hammer away at trying to get MailScanner working again.  I managed to get the install to run without error, but I still do not see MailScanner actively processing any SPAM at all in the "maillog" log file.  It only shows its startup messages, and that's it.  The process ID remains running, but MailScanner is effectively dead (doesn't do any work).  I also did successfully use CPAN to upgrade Spam Assassin to the very latest version, just now.

[root at fs9 log]# spamassassin -V

SpamAssassin version 3.4.4

  running on Perl version 5.10.1

[root at fs9 log]#

After that, I tried MailScanner -lint, and had some issues, which I fixed, until I now have this result:

[root at fs9 ~]# MailScanner --lint

Trying to setlogsock(unix)

Reading configuration file /etc/MailScanner/MailScanner.conf

Reading configuration file /etc/MailScanner/conf.d/README

Read 1500 hostnames from the phishing whitelist

Read 7949 hostnames from the phishing blacklists

Checking version numbers...

Version number in MailScanner.conf (5.3.3) is correct.

Your envelope_sender_header in spamassassin.conf is correct.

Checking for SpamAssassin errors (if you use it)...

Using SpamAssassin results cache

Connected to SpamAssassin cache database

config: registryboundaries: no tlds defined, need to run sa-update

SpamAssassin reported no errors.

Auto: Found virus scanners: clamd

Using locktype = flock

MailScanner.conf says "Virus Scanners = auto"

Found these virus scanners installed: clamd


Filename Checks: Windows/DOS Executable (1

Other Checks: Found 1 problems

Virus and Content Scanning: Starting

Clamd::INFECTED:: Win.Test.EICAR_HDB-1 :: ./1/

Virus Scanning: Clamd found 2 infections

Infected message 1 came from

Virus Scanning: Found 2 viruses


Virus Scanner test reports:

Clamd said " was infected: Win.Test.EICAR_HDB-1"

If any of your virus scanners (clamd)

are not listed there, you should check that they are installed correctly

and that MailScanner is finding them correctly via its virus.scanners.conf.

I don't know what this error means, or how to fix it-I did run "sa-update", and it did not fix it:

config: registryboundaries: no tlds defined, need to run sa-update

Can you please let me know how to fix this?

Also, of interest, I read in the spamassassin.conf that there is a Processing.db, that is in the /var/spool/MailScanner/incoming folder, and to clear it, you delete it, and it should be recreated when MailScanner is restarted, it will be recreated.  I tried that, but it did NOT get recreated, not sure why.  Any ideas?

The bottom line here is that MailScanner is not doing what it should be doing, and that is scanning incoming mail.  I am having a great deal of trouble figure this out.  Please help.  Thank you very much!


Paul Scott
Engineer, Eden USA, Incorporated

866.501.3336 | 951.505.6967 | sales at<mailto:sales at>

Shawn Iverson
shawniverson at<mailto:shawniverson at>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the MailScanner mailing list