New MailScanner Stable v5.0.6-3 install

Mark Meelhuysen mark at
Thu Aug 24 07:43:05 UTC 2017

Hi All!

Forget my previous question! My mistake is even so stupid I am not going to tell you guys :)


Van: MailScanner [ at] Namens Mark Meelhuysen
Verzonden: donderdag 24 augustus 2017 09:39
Aan: MailScanner Discussion <mailscanner at>
Onderwerp: RE: New MailScanner Stable v5.0.6-3 install

Hi Jorge, Shawn and Tom!

Thank you for your input! This solution solved my error regarding Pyzor indeed.
But my MailScanner is still not jumpin in. My maillog shows : localhost MailScanner[2209]: MailScanner Email Processor version 5.0.6 starting...
And my testmessages are still in the postfix queue.
The service btw is running. I was still using MailScanner instead of mailscanner. Also postfix and spamassassin are running.

Thank you for your assistance...


Van: Mark Meelhuysen
Verzonden: woensdag 23 augustus 2017 23:51
Aan: 'MailScanner Discussion' <mailscanner at<mailto:mailscanner at>>
Onderwerp: New MailScanner Stable v5.0.6-3 install

Hi All,

I have for quite some time a 4.84.6 install running with SpammAssassin, ClamAV, Postgrey and Postfix on CentOs 6.9.

Now I have installed a CentOs 7 minimal installation with MailScanner 5.0.6-3, Spamassassin, ClamAv and Postfix.
Ran through the config and everything seems fine.
MailScanner -lint output:

[root at localhost ~]# MailScanner -lint
Trying to setlogsock(unix)

Reading configuration file /etc/MailScanner/MailScanner.conf
Reading configuration file /etc/MailScanner/conf.d/README
Read 1500 hostnames from the phishing whitelist
Read 12886 hostnames from the phishing blacklists

Checking version numbers...
Version number in MailScanner.conf (5.0.6) is correct.

Your envelope_sender_header in spamassassin.conf is correct.
MailScanner setting GID to  (89)
MailScanner setting UID to  (89)

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
pyzor: check failed: internal error, python traceback seen in response
SpamAssassin reported no errors.
Auto: Found virus scanners: clamav
Connected to Processing Attempts Database
Created Processing Attempts Database successfully
There are 0 messages in the Processing Attempts Database
Using locktype = posix
MailScanner.conf says "Virus Scanners = auto"
Found these virus scanners installed: clamav
Filename Checks: Windows/DOS Executable (1
Other Checks: Found 1 problems
Virus and Content Scanning: Starting
./1/ Eicar-Test-Signature FOUND

Virus Scanning: ClamAV found 2 infections
Infected message 1 came from
Virus Scanning: Found 2 viruses
Virus Scanner test reports:
ClamAV said " contains Eicar-Test-Signature"

If any of your virus scanners (clamav)
are not listed there, you should check that they are installed correctly
and that MailScanner is finding them correctly via its virus.scanners.conf.

The only problem I have is that MailScanner is not grabbing in when a new mail is held by Postfix. It also seems the service does not exist:

[root at localhost ~]# systemctl status MailScanner
Unit MailScanner.service could not be found.

I have installed another server for testing and there the service is recognized and started. I have no clue if I missed an error when installing MailScanner.
Btw SElinus is disabled.

Hope some can give me a push in the right direction. Thank you in advance!

With kind regards,


Dit bericht is gescanned op virussen en andere gevaarlijke inhoud en lijkt schoon te zijn.
Meelhuysen IT Solutions<>.

Dit bericht is gescanned op virussen en andere gevaarlijke inhoud en lijkt schoon te zijn.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the MailScanner mailing list