Filename Restrictions Not working

Kevin Miller kevin.miller at
Tue Feb 17 23:02:00 GMT 2015

So I'm thinking maybe it's a permissions issue?  If you put a file in the temp dir that MailScanner uses (probably /var/spool/MailScanner/incoming) and then try to scan that as the user that your MailScanner is running as, does it return a proper response?  What are the permissions on that directory?

Does virus scanning work as advertised if you send an eicar "infected" file?

Kevin Miller
Network/email Administrator, CBJ MIS Dept.
155 South Seward Street
Juneau, Alaska 99801
Phone: (907) 586-0242, Fax: (907) 586-4500
Registered Linux User No: 307357

From: mailscanner-bounces at [mailto:mailscanner-bounces at] On Behalf Of James Nelson
Sent: Tuesday, February 17, 2015 12:34 PM
To: MailScanner discussion
Subject: RE: Filename Restrictions Not working

Hi Kevin,

I've tried with linking directly to filename.rules.conf, I've tried using a filename.rules that points FromOrTo:                default                 \etc\MailScanner\filename.rules.conf , but neither approach is working.

What's especially odd is if explicitly define a blocked file type...say, \.exe$ directly in MailScanner.conf, even THAT doesn't work.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list