Mailscanner loops stops processing emails.

Richard Mealing richard at
Tue May 20 12:33:01 IST 2014

Hi Martin,

Thanks, but that doesn’t work for me.
I changed the Processing attemtps to 0 and now I see clamd timing out and crashing in the logs.

Lots of this -
MailScanner[66580]: Virus Scanning: No virus scanners worked, so message batch was abandoned and re-tried!

Lots of this –
MailScanner[71612]: Cannot find Socket (/var/run/clamav/clamd) Exiting!

My socket does match mailscanner..

But now all the emails seem to be processing and obviously now not being quarantined my mailscanner.

I’m debugging clamd but I can’t find anything obvious in the logs. I’ve opened a thread with the clamd list.

Here’s some of my clamconf –n -

LogFile = "/var/log/clamav/clamd.log"
LogFileMaxSize = "104857600"
LogTime = "yes"
LogVerbose = "yes"
PidFile = "/var/run/clamav/"
TemporaryDirectory = "/tmp"
LocalSocket = "/var/run/clamav/clamd"
MaxConnectionQueueLength = "30"
MaxThreads = "50"
ReadTimeout = "300"
CommandReadTimeout = "7"
MaxQueue = "300"
Debug = "yes"
User = "clamav"
AllowSupplementaryGroups = "yes"
StructuredMinCreditCardCount = "5"
StructuredMinSSNCount = "5"
MaxRecursion = "20"

Here’s my mailscanner processing timeouts –

Max Unscanned Bytes Per Scan = 100m
Max Unsafe Bytes Per Scan = 50m
Max Unscanned Messages Per Scan = 30
Max Unsafe Messages Per Scan = 30

I’m wondering if there is something here I need to change. Any advice would obviously be appreciated!!


From: mailscanner-bounces at [mailto:mailscanner-bounces at] On Behalf Of Martin Hepworth
Sent: 20 May 2014 11:23
To: MailScanner discussion
Subject: Re: Mailscanner loops stops processing emails.

make sure the MailScanner perl script has the -U flag at the top, sounds like the usual taint mode issues.

Martin Hepworth, CISSP
Oxford, UK

On 20 May 2014 10:43, Richard Mealing <richard at<mailto:richard at>> wrote:

I’m having problems with mailscanner where I see the error like - Quarantined message s4K962Jg091731 as it caused MailScanner to crash several times

Here’s my debug –

mailscanner --debug

In Debugging mode, not forking...
Trying to setlogsock(unix)
Building a message batch to scan...
Have a batch of 30 messages.
Can't call method "CombineReports" on unblessed reference at /usr/local/lib/MailScanner/MailScanner/ line 736.

I cannot see any problems with permissions, but I will be glad to share them with the list. Just let me know what you want to look at.

The only thing that seems to fix this is deleting the Processing.db file for mailscanner, then restarting mailscanner. If I have a large queue then it just happens again and I start seeing “Making attempt 2 at processing message s4K9YVUO015387” etc etc.

Does anyone else see this problem or is it just me?



MailScanner mailing list
mailscanner at<mailto:mailscanner at>

Before posting, read

Support MailScanner development - buy the book off the website!

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list