errors after upgrade

Dave Filchak dave.filchak at
Wed Jun 15 17:37:03 IST 2011

I have recently taken over management of a server that I used to manage 
some time ago. The MailScanner install had not been upgraded in some 
time so I decided to upgrade to the latest version. First mistake I made 
was not checking the version BEFORE I ran the upgrade but the person who 
had been managing it said it had not been upgraded in a year or so.

So, I installed the latest version and during the install, I get the 

BEGIN failed--compilation aborted at t/weak.t line 33.
         Test returned status 255 (wstat 65280, 0xff00)
Failed Test Stat Wstat Total Fail  List of Failed
t/weak.t     255 65280    ??   ??  ??
1 test skipped.
Failed 1/32 test scripts. 0/2190 subtests failed.
Files=32, Tests=2190,  2 wallclock secs ( 2.10 cusr +  0.31 csys =  2.41 CPU)
Failed 1/32 test programs. 0/2190 subtests failed.
make: *** [test_dynamic] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.74452 (%build)

RPM build errors:
     Bad exit status from /var/tmp/rpm-tmp.74452 (%build)

When I run MailScanner -V I get:

  MailScanner -V
dualvar is only available with the XS version of Scalar::Util at /usr/lib/perl5/site_perl/5.8.8/Compress/ line 8
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/Compress/ line 8.
Compilation failed in require at /usr/lib/MailScanner/MailScanner/ line 42.
BEGIN failed--compilation aborted at /usr/lib/MailScanner/MailScanner/ line 42.
Compilation failed in require at /usr/sbin/MailScanner line 110.
BEGIN failed--compilation aborted at /usr/sbin/MailScanner line 110.


  service MailScanner status
Checking MailScanner daemons:
          MailScanner:                                      [FAILED]
          incoming sendmail: head: cannot open `/var/run/' for reading: No such file or directory
                                                            [  OK  ]
          outgoing sendmail:                                [  OK  ]

It is receiving and sending mail but I am not seeing anything about MailScanner in the logs so I assume it is not running.

I appreciate all suggestions as to how to troubleshoot/repair this.


Seneca College
School of Media&  Marketing
70 The Pond Road
Toronto, On Canada

More information about the MailScanner mailing list