MS isn't reading hold queue

Jeremy McSpadden jeremy at
Wed Jul 27 04:03:03 IST 2011

Hey List,
Working with a clean 11.04 install, built from scratch. I am unable to track back as to why MS is not picking up the HOLD queue from postfix.

root at smtp3:/etc/MailScanner# grep "Incoming Queue Dir" MailScanner.conf
Incoming Queue Dir = /var/spool/postfix/hold
root at smtp3:/etc/MailScanner# cd /var/spool/postfix/hold/
root at smtp3:/var/spool/postfix/hold# ls
4424D747D8  4622974794  46658747A8  46A00747A9  46DFB747D6  471B7747AD  47589747D7  4794074797  47DD97477D  481A8747D3  4859E747C1  48A5B747AB  48FA5747D4  49365747AC  4974574795
root at smtp3:/var/spool/postfix/hold#

Jul 26 20:59:27 smtp3 postfix/cleanup[596]: 9EC93747D4: hold: header Received: by<> (Postfix, from userid 104)??id 9EC93747D4; Tue, 26 Jul 2011 20:47:16 -0500 (CDT) from local; from=<root at<mailto:root at>> to= <jeremy at<mailto:jeremy at>>
Jul 26 20:59:27 smtp3 postfix/cleanup[596]: 9EC93747D4: message-id=<20110727012417.BED8274795 at<mailto:20110727012417.BED8274795 at>>
Jul 26 20:59:28 smtp3 MailScanner[592]: Connected to Processing Attempts Database
Jul 26 20:59:28 smtp3 MailScanner[592]: Found 0 messages in the Processing Attempts Database

I've tried running --debug, but it seems to be a bug in the software. I am getting this on all of my machines.

Building a message batch to scan...
Insecure dependency in open while running with -T switch at /usr/share/MailScanner//MailScanner/ line 358.  [fail]

I've tried deleting the Processing.db file from /var/spool/MailScanner/incoming and reloading/restarting MS; still no avail. Any help would be appreciated, thanks!

Jeremy McSpadden
Flux Labs, Inc<>
Endless Solutions
Office : 850-588-4626
Cell : 850-890-2543
Fax : 850-254-2955

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list