Zlib and zleb-devel missing, what's unrar, and do I care?

G. Armour Van Horn vanhorn at whidbey.com
Wed Feb 17 19:44:45 GMT 2010

Thanks, Phil, that worked.


On 17/02/2010 05:13, Randal, Phil wrote:
> You'll find unrar on rpmforge's yum repository.
> I'm using clamav / clamd from the same repository, rather than from
> Jules' tarball.
> Cheers,
> Phil
> --
> Phil Randal | Networks Engineer
> NHS Herefordshire&  Herefordshire Council  | Deputy Chief Executive's
> Office | I.C.T. Services Division
> Thorn Office Centre, Rotherwas, Hereford, HR2 6JT
> Tel: 01432 260160
> email: prandal at herefordshire.gov.uk
> -----Original Message-----
> From: mailscanner-bounces at lists.mailscanner.info
> [mailto:mailscanner-bounces at lists.mailscanner.info] On Behalf Of G.
> Armour Van Horn
> Sent: 17 February 2010 11:02
> To: MailScanner discussion
> Subject: Zlib and zleb-devel missing, what's unrar, and do I care?
> I just started setting up a new server, which meant a fresh install of
> MailScanner.
> I ran the RPM-based installer, as I'm running CentOS, and also used the
> ClamAV 0.95.3/SpamAssassin 3.3.0 installer.
> MailScanner reported that there were no AV scanners installed,
> suggesting frequently in maillog that this wasn't a really bright idea
> on my part. I reran the Clam/SA installer a couple of times before
> noticing that it bitched about zlib and zlib-devel not being installed
> early in the process and just kept running until the final success,
> which actually wasn't success at all. Manually installing those allowed
> the install to run, and MailScanner stopped bitching about it. I would
> think that if these elements are central to the installer running, and
> if RHEL/CentOS don't consider them part of the basic install, that they
> ought to be included in the installer (a ton of other things are), or at
> the very least the installer ought to exit at that point with a clear
> message about the trivial fix. (yum install zlib zlib-devel)
> So MS is running merrily along. However, it keeps carping about
> "/usr/sbin/unrar does not exist or is not executable". Okay, it doesn't
> exist. So off to "yum provides */unrar", and learn that it doesn't exist
> in the CentOS universe, apparently. Now what?
> Van

Sign up now for Quotes of the Day, a handful of quotations
on a theme delivered every morning.
Enlightenment! Daily, for free!
mailto:twisted at whidbey.com?subject=Subscribe_QOTD

For photography, web design, hosting, and maintenance,
visit Van's home page: http://www.domainvanhorn.com/van/

More information about the MailScanner mailing list