MailScanner status shows Dead but it isn't

Gary Faith gafaith at
Mon May 11 04:21:54 IST 2009

Anyone ?

>>> "Gary Faith" <gafaith at> 5/7/2009 7:12 PM >>>
After running into an issue upgrading to 4.76 on SLES 10 SP2 x86_64 and getting it figured out and working, I figured I would use check the MailScanner status.  I know MailScanner is working because I can tail the mail log and see it processing but when I run rcMailScanner status, I get this (I added echo's, after I found it showing dead, in the init script).  
Checking for service MailScanner:
Sendmail:                                                             running
Sendmail Incoming:                                               running
Sendmail Outgoing:                                               running
MailScanner:                                                         dead
If I run /usr/sbin/check_MailScanner, I get this:
/etc/init.d # check_MailScanner
MailScanner running with pid 3584 15152 15535 15870 15894 16020
-rw------- 1 root root 5 Apr 13 14:04
mscan:/var/run # ps ax | grep MailScanner
 3584 ?        Ss     0:01 MailScanner: starting child
15152 ?        S      0:20 MailScanner: waiting for messages
15535 ?        S      0:16 MailScanner: waiting for messages
15870 ?        S      0:17 MailScanner: waiting for messages
15894 ?        S      0:16 MailScanner: waiting for messages
16020 ?        S      0:18 MailScanner: waiting for messages

So, why is rcMailScanner status showing MailScanner as dead ?
Gary Faith
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list