Up2date perl problem package perl-5.8.5-36.el4_6.3 is already installed

Remco Barendse mailscanner at barendse.to
Mon Feb 23 08:48:07 GMT 2009

I am running rhel-i386-es-4 and i have a problem running up2date :

Name                                    Version        Rel
perl                                    5.8.5          36.el4_6.3 i386

Testing package set / solving RPM inter-dependencies...
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package perl-5.8.5-36.el4_6.3 is already installed

I did some googling, and i found a message stating that the perl error is 
caused by a perl module MailScanner installed unfortunately no solution. The 
remark there was that they contacted RedHat for support and then the problem 
got solved.

Now i could do the same but unfortunately this is a server i am supporting on 
the other side of the world and the support contract is with RedHat in Japan so 
contacting them is not so easy for me.  Some other post suggested to try and 
force uninstall of perl and then re-installing it, however i have never tried 
this before and i am pretty scared of messing up a production server i have 
extremely difficult physical access to.

If the problem is indeed caused by a perl module MailScanner installed, does 
anybody know how to solve this problem?


More information about the MailScanner mailing list