Malformed UTF-8 Error Message

Glenn glenn at
Fri Feb 20 17:27:53 GMT 2009

I am running MailScanner with Sendmail on Red Hat EL3.  This installation ran 
fine until I put MailScanner 4.73.4-2 on it, along with the Perl module 
updates from the MailScanner web site and the ClamAV update available at the 
time.  When starting MailScanner, I receive the error message:

"Malformed UTF-8 character (unexpected continuation byte 0xbb, with no 
preceding start byte) at /usr/lib/MailScanner/MailScanner/ 
line 3303."

I recently updated MailScanner to version 4.74.16-1 and again added the Perl 
module updates from the MailScanner web site and updated ClamAV to version 
0.94.2.  I still get the same error when starting MailScanner with "service 
MailScanner start".  Sometimes MailScanner does not actually start, and when 
that happens there is no error message, although the command returns "[OK]".

Also, adding the Perl modules seems to have caused a conflict with the Red 
Hat "up2date" updater, as it refuses to download updates, saying:

"package perl-5.8.0-98.EL3 is already installed".

I have another installation of MailScanner on a Red Hat EL4 box that works 
fine.  Is there a way to fix my EL3 box without going to a new version of the 
OS?  Thanks.   -G.

More information about the MailScanner mailing list