{MCP?} Re: CentOS - Removed perl-IO due to bug in updating via 'yum'

Paul Simpkin paul.simpkin at hitec-systems.co.uk
Fri Feb 13 00:19:33 GMT 2009

Thanks, I just tried this:

ERROR: You must upgrade your perl IO module to at least 
reinstall the perl IO moudle (perl-IO) from CPAN (http://search.cpan.org) 

wget http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/IO-1.2301.tar.gz
tar xvfz IO-1.2301.tar.gz
cd IO-1.2301
perl Makefile.PL
make test
make install

And it worked....

Was that bad? 


Sorry panic moment! :(

-----Original Message-----
From: mailscanner-bounces at lists.mailscanner.info [mailto:mailscanner-bounces at lists.mailscanner.info] On Behalf Of Scott Silva
Sent: 13 February 2009 00:07
To: mailscanner at lists.mailscanner.info
Subject: {MCP?} Re: CentOS - Removed perl-IO due to bug in updating via 'yum'

on 2-12-2009 3:31 PM Paul Simpkin spake the following:
> I was told to update my server for other reason, not knowing that 
> perl-IO was used by mailscanner.
> There is a few posts on how to fix CentOS by removing the perl-IO, 
> someone from the Datecenter I rent my server from asked me to remove 
> this and now mailscanner will not start.
> Now when I run ‘yum install perl-IO’ I get the error bellow!
> Can anyone help me reinstall perl-IO now I think perl has been updated?
you can try this one;

Or just enable Hugo's repo and yum install mailscanner.wrapper


MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

More information about the MailScanner mailing list