ClamAV Mailscanner not using clamd

Ghetti, Ron Ron.Ghetti at
Wed Feb 4 05:56:27 GMT 2009



From: mailscanner-bounces at on behalf of Scott Silva
Sent: Tue 2/3/2009 5:44 PM
To: mailscanner at
Subject: Re: ClamAV Mailscanner not using clamd

on 2-3-2009 12:50 PM Ghetti, Ron spake the following:
> Hi,
>  this one seems to be eluding me, I've got the settings in
> MailScanner.conf
>  setup, clamav-daemon is installed and a running process based on this:
>>  ps ax | grep [c]lamd
>> 4957  ?   Ss      0:06    /usr/sbin/clamd
> So I'm looking for some indication that it is being used properly.
>  Any suggestions ?
> Thanks
> -Ron
Are you using a recent version of MailScanner or are you using some
distributions idea of a "safe" version?
Did you install the proper version for your distro?

Maybe you could give info of what OS, which version of MailScanner, clamd, ETC...


 Some Background:
  Dell PowerEdge 2950 8gb Ram
  Ubuntu 7.04
  Perl 5.8.8
  MailScanner 4.68.8 
  Postfix 2.3.8

  ClamAV 94.2 d/loaded from the MailScanner site.
  SpamAssassin 3.2.4

it's been running pretty well for well over a year.

I ran cpan update and tried to install the perl clamav module 

without any luck, I get errors when it tries to compile.  

It's giving me errors saying that clam is too old!  I downloaded that file last week.

I fear I may have mangled the whole thing now.

Originally we turned off Virus scanning because it couldn't keep up with the load.

users expect messages to fly through within 5 or 10 minutes, if it doesn't then I hear about it.

I wanted to try and get that back enabled with the clamd version but it looks like I may have other

issues as well.








More information about the MailScanner mailing list