Email with chinese writing saying No Program Allowed

Paul housey at
Wed Aug 26 14:50:41 IST 2009

>> I have someone sending me an email with chinese writing in it.
>> The problem is mailscanner blocks it as it thinks its a program - No
>> programs allowed (msg-10911-621.txt)
>> I ran the file command on the quarantined file and it does indeed think its
>> an program
>> [root at venice n7OEIC6o017365]# file msg-10911-621.txt
>> msg-10911-621.txt: COM executable for DOS
>> But it just contains chinese characters.
>> This seems to be happening on quite a few emails with chinese writing in
>> them - has anyone seen this before? or got a solution to stop them being
>> blocked?
>> Kind Regards
>> Paul
> Not only chinese, but basically any language containing non-ascii
> characters can fall afoul of these "opportunistic" magic codes. Either
> switch to using file -i, or edit/recompile your file commands magic
> file... For more details, I suggest you do some mailing list
> searches;-).
> Cheers
Hi Glenn

Thanks for your response, I did some searches and saw mention of adding 
a fifth field in filetype.rules.conf

The output of "file -i" on the message in question is

[root at venice n7OEIC6o017365]# file -i msg-10911-621.txt
msg-10911-621.txt: text/plain; charset=iso-8859-1

So I added

allow   -   -   -   text/plain  

to filetype.rules.conf and it seems to have solved my problem.

Thanks for your help


More information about the MailScanner mailing list