[Fwd: error when starting MS]

Neil Wilson neilw at dcdata.co.za
Wed Nov 26 15:15:10 GMT 2008

Julian Field wrote:
>>> What does this produce?
>>> perl -MFilesys::Df -e 'print $Filesys::Df::VERSION;'
>>> It should print the version number of Filesys::Df. If it doesn't 
>>> then try removing the Df.pm file you found, and re-install the 
>>> module from CPAN.
>> I get the following, should I try removing it anyway, and then 
>> re-installing it?
>> perl -MFilesys::Df -e 'print $Filesys::Df::VERSION;'
>> 0.92
> So that worked. Try removing and reinstalling it anyway, just in case 
> that helps.
Not sure if anyone has any other ideas, but for some reason I still 
can't get my MS to start after an upgrade to the latest version.

Below is the full error.

Starting MailScanner...Can't locate Filesys/Df.pm in @INC (@INC 
contains: /opt/MailScanner/lib /usr/lib/perl5/5.8.6/i486-linux 
/usr/lib/perl5/5.8.6 /usr/lib/perl5/site_perl/5.8.6/i486-linux 
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl . 
/opt/MailScanner/lib) at /opt/MailScanner/bin/MailScanner line 67.
BEGIN failed--compilation aborted at /opt/MailScanner/bin/MailScanner 
line 67.

I've tried re-installing the module from cpan and from source with still 
no luck, the module definitely exists, and MS even detects it when I try 
and re-install MS


Below is from the install.log

Oh good, module Filesys::Df version 0.90 is already installed.

Please shout if anyone has any other suggestions.



This email and all contents are subject to the following disclaimer:

More information about the MailScanner mailing list