SV: Local State Dir - /var/lib/spamassassin - SARE rules no hits

Daniel Flensburg Daniel.Flensburg at
Mon Nov 24 15:38:20 GMT 2008

I tried using the command "su - postfix -s /bin/bash" and I could ls cd and nano the *cf files in /var/lib/spamassassin/3.XXXXX

BUT, now I cannot SA-LEARN with MailWatch. Have no idea if they are related but it happended at the same time. (No results In MailWatch > Bayes Info either)

SA Learn: error code 13 returned from sa-learn: bayes: expire_old_tokens: locker: safe_lock: cannot create tmp lockfile /var/www/.spamassassin/ for /var/www/.spamassassin/bayes.lock: Permission denied bayes: locker: safe_lock: cannot create tmp lockfile /var/www/.spamassassin/ for /var/www/.spamassassin/bayes.lock: Permission denied Learned tokens from 0 message(s) (1 message(s) examined)

My bayes files are not in /var/www either, but in /opt/MailScanner/bayes

I have rebooted. What happened?!


-----Ursprungligt meddelande-----
Från: mailscanner-bounces at [mailto:mailscanner-bounces at] För Glenn Steen
Skickat: den 24 november 2008 15:22
Till: MailScanner discussion
Ämne: Re: Local State Dir - /var/lib/spamassassin - SARE rules no hits

2008/11/24 Daniel Flensburg <Daniel.Flensburg at>:
> Hi Kai!
> Sorry about the reply button, I think you are right.
> I tried the setting below and restarted the server. I cannot see any SARE hits yet.
> I'm pretty sure it's not working. (tried to send text that another working server get SARE hits on outgoing tests, no hits on "my"side)
> What is the best way to test if rules in /var/lib/spamassassin are working correctly?
> Why does the two commands below give different results?
> spamassassin -D --lint
> /opt/MailScanner/bin/MailScanner --debug --debug-sa
Because the first is run as root and the second is run a postfix. Stop
"checking" things as root, when it comes to SA. Although the risk of
it actually hurting you is minimal (provided you've set bayes perms
correctly) it doesn't help you either.

As a postfix user, your first gut reaction should be to test
everything manually as your postfix user...!:-).
So start by becoming postfix via "su - postfix -s /bin/bash", then use
normal tools like "cd", "ls" and "less" to make sure you can a) reach
the files and b) read the files. If the actual sa-update/SARE
directories are correct (you can read them, as postfix), then likely
the problem is "closer to the root directory". When you've fixed any
permission issues, test the plain spamassassin command again.

-- Glenn
email: glenn < dot > steen < at > gmail < dot > com
work: glenn < dot > steen < at > ap1 < dot > se
MailScanner mailing list
mailscanner at

Before posting, read

Support MailScanner development - buy the book off the website! 

More information about the MailScanner mailing list