It done broke. "Returned 22 with signal 0".

ravenpi at ravenpi at
Tue Feb 12 00:41:05 GMT 2008

Hey, all.  Long-time MailScanner user, always been very happy with it.  Have
it installed on my month-old Ubuntu box, when, suddenly, it died this past
Sunday.  Syslog says:
Mailscanner: Process did not exit cleanly, returned 22 with signal 0

Running in debug mode says:
max message size is '40k'
max message size is '40k'
Ignore errors about failing to find EOCD signature
Can't use an undefined value as a symbol reference at
/usr/share/MailScanner/MailScanner/ line 1495.

Lines 1494 & 1495 are:
    $handle = IO::File->new_tmpfile;

The funny thing is, when I change 1494 to
$handle = IO::File->new_tmpfile or die "It didn't work: $!"
Sure enough, it dies.  So, for the hell of it, I made a mini Perl
use IO::File;
$handle = IO::File->new_tmpfile;

And that worked just fine, so Perl seems okay (no?).

I did a full uninstall and re-install, including re-tweaking my config
files, and it worked... for about 15 messages, then is doing the exact same
thing all over again.

ANY ideas?  Or do I have to regen my damn box?  (Note: I also poked around
in all the usual places for signs of an intruder, but haven't found

Thanks  much,

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list