Sophos not running correctly after most recent update

Stef Morrell stef at
Fri Apr 4 13:53:05 IST 2008

Hello all,

Overnight, MajorSophos script fired via cron as normal and downloaded
the latest Sophos (4.28) installing via the install scripts in
Mailscanner as usual.

At this point, Sophos stopped working completely

# /opt/MailScanner/lib/sophos-wrapper /usr/local/Sophos
Error initialising detection engine - missing part of virus data

I've tried completely removing /usr/local/Sophos and reinstalling, but
get the same error. I'm presuming it can see the ide directory, as
without it I instead get the error

Error initialising detection engine - missing main virus data

It's as though the virus data itself is nerfed in this release. Perhaps
I can get an older version from somewhere and use more ide files until
the next release, though the Sophos website is unhelpful in this regard.

Has anyone the same problem, or a brilliant idea?


Stefan Morrell          | Operations Director
Tel: 0845 3452820       | Alpha Omega Computers Ltd
Fax: 0845 3452830       | Incorporating Level 5 Internet
stef at         | stef at

Alpha Omega Computers Ltd, Unit 57, BBTC, Grange Road, Batley, WF17 6ER.
Registered in England No. 3867142.  VAT No. GB734421454

More information about the MailScanner mailing list