Beta release 4.61.3
jtm.koekkoek at home.nl
Fri Jun 15 00:07:37 IST 2007
I agree with the consistency argument! I would like to add that I
personally think that all MailScanner executables should start with ms-,
and that underscores should be replaced by hyphens. By doing this it's
easier to just put those scripts in the /usr/bin or /usr/sbin
directories. Of course the ms- prefix can be replaced by another prefix.
I have another question for Julian: Why are all wrappers scripts that
need to be executed in order to execute the virusscanner. Isn't it
better to put the required code in modules. E.g.
MailScanner::VirusScanner::BitDefender? Leaving out the shell
environment completely is more beautiful. It could even improve
performance as well. I know amavis-ng does have some modules available.
I'd even be interested in helping to migrate/rewrite the code. Please
let me know if I can be of service.
On Thu, 2007-06-14 at 14:10 +0300, Nerijus Baliunas wrote:
> On Thu, 14 Jun 2007 11:04:15 +0100 Julian Field <MailScanner at ecs.soton.ac.uk> wrote:
> > I have just released the latest beta, 4.61.3.
> Could you please rename /etc/cron.daily/sa-update to update_spamassassin
> as per discussion in "/etc/cron.daily/sa-update rpm conflict" thread?
> Because it clashes now with atrpms spamassassin package and will
> probably clash with Fedora package in the future. And it will be consistent
> with update_phishing_sites and update_virus_scanners :)
More information about the MailScanner