Releasing from quarantine - postfix

Simon Pollitt simon.pollitt at
Sat Jun 2 04:35:32 IST 2007

(Tried to send this last week but it didn't get through?)

I have a newly installed single instance (HOLD method) postfix +  
Mailscanner install, slightly complicated by running "inside" Bynari  

All is going well as far as scanning, blocking and mailing - until  
I've tried to release a message from quarantine.

I've followed the instructions at:

with the directory modifications for Insight:


if [ -z "$1" ]; then
         echo "Syntax: $0 <Message-ID> i.e. 5B604228086.932F0 (case sensitive)"

#change in the quarantine folder
folder=`find /var/spool/MailScanner/quarantine/ -name $1 `
cd $folder

#set the mailfile executable
mailname=`echo $1 | cut -d . -f1`
chmod u+x $mailname

#lets get the first character
char=`echo $1 | cut -b 1-1`

#copy the mail
cp -a $mailname /opt/insight/var/spool/postfix/incoming/

echo Mail $mailname released

The problem is that, while this script runs just fine and pushes the  
message into the "incoming" directory, it then goes through the  
Mailscanner scanning process again - which it of course fails...

My postfix config uses:
MTA = postfix
Incoming Queue Dir = /opt/insight/var/spool/postfix/hold
Outgoing Queue Dir = /opt/insight/var/spool/postfix/incoming

and header_checks contains:
/^Received:/ HOLD

I believe that all of the settings are correct because viruses and  
especially spam are being detected like crazy.  I am occasionally  
getting duplicate messages delivered and also (even more occasionally)  
getting messages without bodies being delivered - this does make me  
suspicious that something is not configured cleanly here.

Any suggestions as to where I might look to re-spool messages from  
quarantine and also how concerned about the duplicates I should be?  I  
would be most thankful for any assistance,


More information about the MailScanner mailing list