Debugging &

Glenn Steen glenn.steen at
Thu Feb 9 15:07:12 GMT 2006

On 09/02/06, Jeff Davis <jeff at> wrote:
> I've narrowed my problem.
> Everything including mailwatch works fine except
> when I have Use Spamassassin = yes
> Then the messages just sit in the hold queue.
> I tried turnning on debugging in MailScanner.conf
> and I see this when I restart.
> Is this a db permissions problem?  (That line has a CREATE TABLE statement.)
> Starting MailScanner daemons:
>          incoming postfix:                                 [  OK  ]
>          outgoing postfix:                                 [  OK  ]
>          MailScanner:       In Debugging mode, not forking...
> Can't call method "do" on an undefined value at
> /usr/lib/MailScanner/MailScanner/ line 172.
>                                                            [  OK  ]

Yes, very likely. Your Run As user/group need be able to create the
SQLite SA cache db-file in /var/spool/MailScanner/incoming. If you
have upgraded, you might have done the same type of no-no I did....
Which is to say that I ran MailScanner --lint _before_ I had run the
upgrade_MailScanner_conf ... The configuration had a spurious line in
it that resulted in the lint running as root, creating the spam cache
db with root privs ... which postfix (of course) couldn't live
with:-). If this is is, you need remove that file, then try start
MailScanner again.

-- Glenn
email: glenn < dot > steen < at > gmail < dot > com
work: glenn < dot > steen < at > ap1 < dot > se

More information about the MailScanner mailing list