New Install Problem

Mike Kercher mike at CAMAROSS.NET
Mon Jul 4 19:03:57 IST 2005

I recently installed a new MS box running CentOS 4.1 and installed the RPM
MS dist.  I also, for the first time, used the SA/Clam install, but
something isn't working right.

Jul  4 12:57:09 avenger MailScanner[11151]: MailScanner E-Mail Virus Scanner
version 4.42.9 starting... 
Jul  4 12:57:12 avenger MailScanner[11151]: SophosSAVI 3.95 (engine 2.30)
recognizing 106709 viruses 
Jul  4 12:57:12 avenger MailScanner[11151]: SophosSAVI using 79 IDE files 
Jul  4 12:57:12 avenger MailScanner[11151]: ClamAV Perl module not found,
did you install it? 

I have tried reinstalling Mail::ClamAV via CPAN multiple times and get the

Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/Mail-ClamAV....#     Failed test (t/Mail-ClamAV.t at line 9)
#     Tried to use 'Mail::ClamAV'.
#     Error:  Had problems bootstrapping Inline module 'Mail::ClamAV'
# Can't load
for module Mail::ClamAV: cannot open shared object file: No
such file or directory at
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/ line 230.
#  at /usr/lib/perl5/site_perl/5.8.5/ line 500
#  at /root/.cpan/build/Mail-ClamAV-0.17/blib/lib/Mail/ line 193
# BEGIN failed--compilation aborted at
/root/.cpan/build/Mail-ClamAV-0.17/blib/lib/Mail/ line 537.
# Compilation failed in require at (eval 1) line 2.
t/Mail-ClamAV....NOK 1"all" is not defined in %Mail::ClamAV::EXPORT_TAGS at
t/Mail-ClamAV.t line 11
Can't continue after import errors at t/Mail-ClamAV.t line 11
# Looks like you planned 10 tests but only ran 1.

        Test returned status 10 (wstat 2560, 0xa00)
DIED. FAILED tests 1-10
        Failed 10/10 tests, 0.00% okay
Failed Test     Stat Wstat Total Fail  Failed  List of Failed
t/Mail-ClamAV.t   10  2560    10   19 190.00%  1-10
Failed 1/1 test scripts, 0.00% okay. 10/10 subtests failed, 0.00% okay.
make: *** [test_dynamic] Error 2
  /usr/bin/make test -- NOT OK
Running make install
Appending installation info to
Files found in blib/arch: installing files in blib/lib into architecture
dependent library tree
  /usr/bin/make install -j3 -- OK

If I define clamavmodule in my MailScanner.conf, MS doesn't see my
clavavmodule.  So I have to use SophosSavi and clamav.  Any ideas on where
to look for the resolution?


------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the Wiki ( and
the archives (

Support MailScanner development - buy the book off the website!

More information about the MailScanner mailing list