postfix: Process did not exit cleanly

Drew Marshall drew at THEMARSHALLS.CO.UK
Sat Jan 22 00:07:12 GMT 2005

    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "US-ASCII" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Rocky McCamey wrote:
      I installed from the tar on the website, and I still get that
      error.  I have also gone ahead and unmerged postfix and then
      merged it
      back again, and still the same thing.


So to re-cap
 1. With out MailScanner Postfix runs fine?
 2. You install MS and Postfix complains with exit errors?
 3. You checked that the sendmail binary is pointing to the correct
    Postfix equivalent and not an 'old' Sendmail one?
 4. Are all your spool directory paths in MailScanner.conf true paths
    with no sym links?
 5. Have you any mail in the mail queue (mailq will do it)?
 6. Does Postfix complain if you just start it with out MailScanner
    (postfix start)?
 7. With Postfix stopped, set the debug options on in MailScanner.conf
    and the start just MailScanner and check the output (Just in case).
I'll go with just the luck 7 for now! ;-) Let me know how you get on.


In line with our policy, this message has been scanned for
viruses and dangerous content by MailScanner, and is
believed to be clean. ------------------------ MailScanner list
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the MAQ (
and the archives (

Support MailScanner development - buy the book off the website!

More information about the MailScanner mailing list