New to group Compilation problems on RHEL 3.0

James Marcinek jmarc1 at
Sat Sep 18 18:45:55 IST 2004

By the way I never configured spamassassin to work with postfix. Do I still need
to do this or will this now be configured by MailScanner?



"James Marcinek" <jmarc1 at> wrote:
> Hello Everyone,
> First thanks for any help I'm about tho recieve. I've been reading the
> documentation for this all day for integration into Postfix, Spamassassin and
> clamav. I have configured all the proper files and installed via the rpm
> However I get the following error when trying to start the service:
> [root at srv01 BUILD]# service MailScanner start
> Starting MailScanner daemons:
>          incoming postfix:                                 [  OK  ]
>          outgoing postfix:                                 [  OK  ]
>          MailScanner:       Can't locate Archive/ in @INC (@INC
> /usr/lib/MailScanner /usr/lib/perl5/5.8.0/i386-linux-thread-multi
> /5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
> e_perl/5.8.0 /usr/lib/perl5/site_perl
> x-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
> lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .
> ner) at /usr/lib/MailScanner/MailScanner/ line 46.
> BEGIN failed--compilation aborted at
>  line 46.
> Compilation failed in require at /usr/sbin/MailScanner line 52.
> BEGIN failed--compilation aborted at /usr/sbin/MailScanner line 52.
>                                                            [  OK  ]
> When a service MailScanner status is given, it is not running? Thank goodness
> that my postfix is still running.
> From what I can tell it's the perl module Archive::Zip
> (perl-Archive-Zip-1.13-1.src.rpm). The rpm didn't appear to work
> during the build so I figured that I would do it from the src tarball (via the
> make) which gave an error about the pod2man command (couldn't be found) but
> in /usr/bin. This confused me a bit as it was already included in the PATH
> already??? The perl Makefile.PL worked fine but the Makefile didn't look so
> good. when I tried to issue the make command I recieved errors. I looked at
> Makefile and found what looked like parts of lines, some lines containing a
> single quote at the beginning or end of a statement (like a path statement),
> etc. It appeared like syntax errors in the file but I don't know what's valid
> and what's not. I looked on the archives and could not find anything that
> specifically answers this.
> Thanks,
> james

------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the MAQ ( and
the archives (

More information about the MailScanner mailing list