MailScanner not working after Perl upgrade to 5.8.5

Mike Kercher mike at CAMAROSS.NET
Tue Nov 9 12:49:07 GMT 2004

Michael Keightley wrote:
> We run MailScanner-4.34.4 on Solaris 9 with SpamAssassin-3.0.1.
> Our Perl installation (5.6.1) was a bit of a mess here, so I decided
> to start again from fresh with 5.8.5.  This came as a Solaris package
> from I installed all the modules listed below that
> seemed to be relevant to MailScanner, then swapped over the version
> of Perl from 5.6.1 to 5.8.5.
> MailScanner started up OK, but it didn't seem to actually process any
> of the mail.  I got of these messages in the maillog:
> MailScanner[16017]: MailScanner E-Mail Virus Scanner version 4.34.4
> starting...
> but that was it.  I tried disabling SpamAssassin, but still no joy.
> I had to change back to Perl 5.6.1.  #
> Anyone one got any ideas?  How do I go about debugging this?
> Modules installed:

I had a similar issue the other day when I upgrade a box from Redhat 7.3 to
RH 8 to RH 9 to Centos 3.3  This upgraded perl to 5.8.x from 5.6.x.  I ended
up having to reinstall all of my perl modules so that they existed in the
NEW perl installation.  It wasn't fun, but it works like a champ now.


------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the MAQ ( and
the archives (

More information about the MailScanner mailing list