4.26.7, bayes rebuild, confused.

Jeff A. Earickson jaearick at COLBY.EDU
Sun Feb 1 20:39:31 GMT 2004


   I tried an upgrade from 4.25-14 to 4.26.7.  Setup: Sol 9,
SA 2.63.  I got gobs of:

   Skipping SpamAssassin while waiting for Bayes database to rebuild

messages with 4.26.7.  The zero byte file /tmp/MS.bayes.rebuild.lock
appeared after I restarted MS, and it never seems to go away.  I
tried things with both "Rebuild Bayes Every = 0" and with this set
to 86400.  Same deal.  I'm afraid to try "Wait During Bayes Rebuild = yes"
because if it never rebuilds then no mail gets delivered, right?

A rebuild should only take a few seconds, right?

I tried stopping MS, removing /tmp/MS.bayes*, restarting -- still no
luck.  I've fallen back to 4.25-14 for the moment.

BTW, I have a cron job to do bayes spam/ham learning with

  $SALEARN --prefs-file=$PREFS --rebuild  --force-expire

at the top.  Should I still do this rebuild and force-expire in this

More information about the MailScanner mailing list