starting errors on suse with latest Version

Stephen Swaney steve.swaney at FSL.COM
Mon Aug 2 13:24:51 IST 2004

> -----Original Message-----
> From: MailScanner mailing list [mailto:MAILSCANNER at JISCMAIL.AC.UK] On
> Behalf Of Marcel Blenkers
> Sent: Monday, August 02, 2004 7:54 AM
> Subject: Re: starting errors on suse with latest Version
> Hi,
> > At 12:13 02/08/2004, you wrote:
> > >I downloaded the Version for SuSE and installed it with
> > >
> > >Then i edited the new MailScanner.conf which had the Lock Type again
> > >uncommented, so i said it would be flock.
> > >
> > >Then i tried to restart the System..and it did not work properly.
> > >
> > >rcpMailScanner stop deleted the pid-file under /var/run.
> > >
> > >rcpMailScanner start did not create a new one, so my logfile only
> > >contained errors, which said, that this pid-file cannot be found.
> >
> > What MTA are you running?
> > What are your "Run As User" and "Run As Group" set to?
> >
> MTA is sendmail
> Run As User and Run As Group are empty, as stated in the Config-File.
> # User to run as (not normally used for sendmail)
> etc.

I am working on two SuSE installs on SuSE 8.1 (sendmail) and 9+ (Postfix)and
there were four problems that I remember encountering with the MailScanner
init script.

1. The script was installed in /etc/init.d/init.d/MailScanner. I had to move
it to /etc/init.d and remove the then empty directory /etc/init.d/init.d/

2. There were permission problems with the files. I think
simply removing the existing pid files solved the problem.

3. SuSU uses different function names for the Red Hat "success" function. In
SuSE it's "log_success_msg".

4. The ". /etc/sysconfig/network/" call doesn't work. On SuSE this is a

I was waiting until Julian returned from his jaunt until I reported there
problems. Guess now is the time.

Attached are the very quick hacks I made to the MailScanner init script just
to get it running. When I have some time I'll try to make it a bit more
universal and elegant. If anyone has already made these corrections, please
let us know.


Stephen Swaney
Fortress Systems Ltd.
Steve.Swaney at

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Fortress Systems Ltd.

-------------------------- MailScanner list ----------------------
To leave, send    leave mailscanner    to jiscmail at
Before posting, please see the Most Asked Questions at     and the archives at

    [ Part 2, Application/OCTET-STREAM (Name: "MailScanner.init.SuSE")  ]
    [ 12KB. ]
    [ Unable to print this part. ]

More information about the MailScanner mailing list