problem with on non-RPM system

Tim Heaney theaney at CABLESPEED.COM
Sun Aug 1 21:50:50 IST 2004

I have a working MailScanner installation on a non-RPM-based Linux
machine. I just attempted to upgrade to 4.32.5 using the
script, but I ran into some problems. I have a newer version of Perl,
along with all of the modules required by MailScanner, installed in
/usr/local/bin, so I ran

  # ./ --perl=/usr/local/bin/perl

  Your /usr/src/redhat, /usr/src/RPM or /usr/src/packages
  tree is missing.
  If you have access to an RPM called rpm-build or rpmbuild
  then install it first and come back and try again.

I don't understand why it needs this for the non-RPM version (maybe
the problem is right here?), but I do have rpm installed, so I kept
going. I don't have any of the directories mentioned, but I do have a
/usr/src/rpm, so I linked /usr/src/RPM to that and tried again

  # ./ --perl=/usr/local/bin/perl

  Okay, you have /usr/src/RPM.

  Writing a .rpmmacros file in your home directory to stop
  unpackaged files breaking the build process.
  You can delete it once MailScanner is installed if you want to.

  This script will pause for a few seconds after each major step,
  so do not worry if it appears to stop for a while.
  If you want it to stop so you can scroll back through the output
  then press Ctrl-S to stop the output and Ctrl-Q to start it again.

  If this fails due to dependency checks, and you wish to ignore
  these problems, you can run
      ./ --nodeps

  Rebuilding all the Perl modules for your version of Perl

  Oh good, module ExtUtils::MakeMaker version 6.05 is already installed.

  Oh good, module Net::CIDR version 0.09 is already installed.

  Attempting to build and install perl-IO-stringy-2.108-1
  Missing file perl-rpm/perl-IO-stringy-2.108-1.src.rpm. Are you in the right directory?

  Missing file /usr/src/RPM/RPMS/noarch/perl-IO-stringy-2.108-1.noarch.rpm.
  Maybe it did not build correctly?
  * This Could Be A Problem. Press Ctrl-S Now!!

It seems to be complaining that I don't have a


which is true, I don't have a perl-rpm directory at all. I do have


but I already have IO-stringy-2.109 installed, so why would it be
looking for 2.108 at all, let alone the RPM version?

I extracted


and updated my installation the old way and all seems to be well, but
how is this method supposed to work?



Hardware: AMD Athlon 1200MHz, 1024 MB RAM, 60 GB HDD.
Software: Slackware Linux 9.1, Sendmail, SpamAssassin, MailScanner
Virus Scanners: F-Prot
Volume: 20 messages/day

-------------------------- MailScanner list ----------------------
To leave, send    leave mailscanner    to jiscmail at
Before posting, please see the Most Asked Questions at     and the archives at

More information about the MailScanner mailing list