readqf: cannot open ./d* (including last MailScanner)

Julian Field mailscanner at
Mon Oct 6 16:42:10 IST 2003

Sure you haven't got your old copy of MailScanner running at the same time
as your new one?
Or an old sendmail process still running?

At 16:10 06/10/2003, you wrote:
>My config:
>- MailScanner-4.11-1 but today I have tried too MailScanner-4.24-5 and
>   the errors has increased considerably (may be because it's faster?)
>- mcafee
>- Sendmail 8.12.3-6.6
>- Linux Kernel 2.4.22
>I've got lots of this annoying error in my logs and although
>the messages are sent correctly sendmail generates an error mail
>to the sender for every message with this log. I woudn't care about
>this cause as I said all the messages are sent but my users complain
>about the error messages they receive.
>An example:
>grep h95LST48031790: mail.log
>Oct  5 23:28:30 avant sm-mta[31790]: h95LST48031790:
>from=<julianov57 at>, size=1659, class=0, nrcpts=1,
>msgid=<BAY7-F88YEIEktho3sD0000c56e at>, proto=ESMTP,
>daemon=MTA, []
>Oct  5 23:28:40 avant sm-mta[31815]: h95LST48031790:
>to=<sf2 at>, delay=00:00:10, xdelay=00:00:00, mailer=local,
>pri=120651, dsn=2.0.0, stat=Sent
>--> Here the message has been sent but...
>Oct  5 23:28:49 avant sendmail[31827]: h95LST48031790: SYSERR(root):
>readqf: cannot open ./dfh95LST48031790: No such file or directory
>After sending it seems to trying to process it again!!
>Oct  5 23:28:49 avant sendmail[31827]: h95LST48031790:
>to=<sf2 at>, delay=00:00:19, xdelay=00:00:00, mailer=local,
>pri=120651, dsn=5.2.3, stat=Service unavailable
>Oct  5 23:28:49 avant sendmail[31827]: h95LST48031790: h95LSn62031827:
>DSN: Service unavailable
>In the list archives are some people asking about this error but I think
>there's no solution yet.
>If I'm not wrong MailScanner puts the scanned messages from to
>mqueue and then a 'sendmail -q -OQueueDirectory=/var/spool/mqueue'
>process this queue. Could it be that mailscanner put first the mail
>header (./q*) and then the data (./d*) if the time between the copy of
>the header and the data would be substantial (for example 1 or more
>seconds) that would explain the problem, but I don't know how to monitor
>It's not a fs lock problemm I have updated to kernel 2.4.22 where the
>flock() is now Posix 2001 compatible (actually from 2.4.21 is
>Today I have upgraded to MailScanner 4.24-5 but there were many more
>readqf error messages so I've downgraded after some hours (the rest
>worked perfectly and faster! ;-)
>We'll keep trying to find out a solution, any help would be appreciated.
>Ramon Acedo.

Julian Field
MailScanner thanks transtec Computers for their support

PGP footprint: EE81 D763 3DB0 0BFD E1DC  7222 11F6 5947 1415 B654

More information about the MailScanner mailing list