SpamAssassin 2.55 problem

Paul zen23003 at ZEN.CO.UK
Sun Jun 29 12:33:47 IST 2003

Phew, glad it wasn't just me.  I upgraded from MailScanner 3.x and
SpamAssassin 2.43 earlier in the week and have had major problems ever

The box I'm running on is VERY low spec (an old Celeron with 32 Mb
memory) so I thought that was the problem.

The processing of each message was taking absolutely ages.  I tried
changing the number of MailScanner processes and the number of messages
to be processed in a batch, but it didn't make a huge difference.
Yesterday morning I had hundreds of messages in the queue.  They were
taking 11 hours to process!

Skipping SpamAssassin's rbl checking made no difference, neither did
enabling SpamAssassin's rbl checks but removing some of the SpamAssassin
rbl checks that were timing out.

I have recently turned off SpamAssassin and enabled MailScanner's spam
checking.  This has solved the problem.

If I run SpamAssassin in debug mode against a sample spam email like

spamassassin -tD < sample-spam.txt

it takes about 12 seconds for the output to begin.

Running the same command with the 2.4x version of SpamAssassin took 2 or
3 seconds.  I guess that's the clue to it.

Does anyone have SpamAssassin 2.55 working well?

----- Original Message -----
From: "James Pifer" <mailscannerlist at TNJINFL.COM>
Sent: 28 June 2003 14:32
Subject: Re: Mail getting stuck in - Update

> We uninstalled SpamAssassin 2.55.x and put our previous version back
> which was 2.50.x. (don't remember the exact versions and can't get to
> them right now). Anyway, this fixed the problem. We were able to
> Spam Checking and mail is being delievered.
> Anyone else had this kind of issue with SpamAssassin 2.55.x?

More information about the MailScanner mailing list