Problem installing on a RaQ4

Julian Field mailscanner at
Fri Jan 17 15:09:38 GMT 2003

Unfortunately this can easily become a vicious circle, with a depending on
b and d depending on a.

If you find yourself caught like this, and the
         perl Makefile.PL
         make test
         make install
won't work for File-Spec, then you will find the module is only 1 file
(, and the commands above will give you a good idea of where to put it.

At 14:23 17/01/2003, you wrote:
>You might try downloading and installing File::Spec by hand and then try
>-----Original Message-----
>From: MailScanner mailing list [mailto:MAILSCANNER at JISCMAIL.AC.UK] On
>Behalf Of Joe Quinn
>Sent: Friday, January 17, 2003 8:16 AM
>Subject: Problem installing on a RaQ4
>I'm trying to do a fresh install on a new RaQ4 but have hit problems.
>I've done a few RaQ4's before and it was easy!
>When I run the./ command I get;
>Your copy of the Perl module ExtUtils::MakeMaker........
>run this first.........../
>but when I do that it still fails;
>[root MailScanner-4.11-1]# ./
>Can't locate object method "rel2abs" via package "File::Spec" at
>Makefile.PL line 55. BEGIN failed--compilation aborted at Makefile.PL
>line 57.
>make: *** No targets specified and no makefile found.  Stop.
>make: *** No rule to make target `install'.  Stop.
>Done. Please now run ./ again.
>[root MailScanner-4.11-1]#
>so I ran ./ again with the same results???
>This time I read the FAQ and checked to ensure only one copy of perl was
>Any ideas?

Julian Field
MailScanner thanks transtec Computers for their support

More information about the MailScanner mailing list