changing user and group

Lindsay Snider lindsay at
Tue Feb 18 23:07:11 GMT 2003

On the server I'm having difficulty setting the user/group id, I am also 
running perl 5.6.1-34.99.6.  For me, the mailscanner is dieing on line 740 of  Line 740 reads:

unless (chdir $queuedirname) {

Within the 'unless', a log entry is posted and next is called.  However, 
nothing within or after the loop gets executed.    I tried adding 'chdir 
$queuedirname' a few lines before the 'unless' and that then too dies.  I 
debug printed the chdir $queuedirname and switched to the directory as the 
user in bash and it worked fine.  I also wrote a perl script that setuid's 
and changes to the directory, that too worked.  Seems to be a perl bug.  

Cameron, do you want to see if mailscanner is dieing at the same place for 
you?  I'm not in a good position to upgrade my perl but if that is something 
you can try, want to see if that helps?

Good luck!

On Tuesday 18 February 2003 17:35, you wrote:
> Yes, as I was just testing it, so I changed it to my uid and gid.
> I'm running Red Hat 7.3 with all the latest rpms.
> sendmail 8.11.6-15
> perl 5.6.1-34.99.6
> on a celeron 400
> Cameron
> > Does the user you are running as have a real home directory that it can
> > read from and write to?
> > --
> > Julian Field
> >
> > MailScanner thanks transtec Computers for their support

More information about the MailScanner mailing list