KavDaemonClient (Was Re: F-Secure 4.50 not supported)

Nerijus Baliunas nerijus at USERS.SOURCEFORGE.NET
Wed Apr 30 14:58:05 IST 2003

An, 2003-04-29 20:40, Julian Field wrote:

> Run as
>          cd /root/q
>          AvpDaemonClient .
> works fine. It doesn't need the full pathname.
> Here is a chunk of the output from it:
> >Current object: ./eicars/dfh3MENF6X020229
> >Test result: 4
> >Known viruses were detected

AvpDaemonClient from Sample1 directory does not find viruses at all,
even if I run it with full path:

# pwd

# kavscanner -I0 .

|            Kaspersky Anti-Virus for Linux             |
|         Copyright(C) Kaspersky Lab. 1998-2002         |
|                     Version                   |
Current object: /var/virge/temp/
/var/virge/temp/a infected: EICAR-Test-File

# AvpDaemonClient1 .
Test result: 0
No viruses were found

# AvpDaemonClient1 /var/virge/temp
Test result: 0
No viruses were found

# AvpDaemonClient1 /var/virge/temp/a
Test result: 0
No viruses were found

AvpDaemonClient from Sample directory works, but only with full path:

# AvpDaemonClient .
Test result: 1
Test result: 0x31, flags: 0x100
Virus scan was not complete
Found viruses:
Return code: 1

# AvpDaemonClient /var/virge/temp
Test result: 4
Test result: 0x34, flags: 0x100
Known viruses were detected
Found viruses: /var/virge/temp/a        infected: EICAR-Test-File

> Please can you work out why yours doesn't work the same way as mine?
> If you just run the command "AvpDaemonClient ." then please do a "which
> AvpDaemonClient" to check where it is actually getting it from.

I really don't know why it works for you and doesn't for me. What are
your kavdaemon parameters? I run it as
/opt/AVP/kavdaemon -I0 -Y /var/virge/temp/ /var/spool/ :
# ps axw|grep kav
14755 ?        S      0:00
14756 ?        S      0:00 /opt/AVP/kavdaemon -I0 -Y /var/virge/temp/

System is RH 7.3.
I tried running AvpDaemonClient with full path
(/usr/local/bin/AvpDaemonClient), it doesn't change anything.

The fact is, that it doesn't work here on 2 different systems, and I
asked kaspersky support about this problem, and they told that "." is
not supported by kavdaemon for security reasons. So is there any
possibility to pass full path to kavdaemon client? IMHO it would solve
all the problems.


More information about the MailScanner mailing list